PDA

Επιστροφή στο Forum : Laptop και φόρτιση μπαταρίας



Jimakos_Sn
21-02-12, 15:32
Έχω ένα λάπτοπ που ενώ λειτουργεί κανονικά δεν φορτίζει την μπαταρία του. Την μπαταρία την φόρτισα εξωτερικά και βλέπει μια χαρά το ποστοστό της όπως
επίσης δουλεύει μια χαρά μόνο απο μπαταρία. Αυτό που έχω συμπεράνει είναι οτι το λάπτοπ δεν καταλαβαίνει οτι μπήκε καλώδιο απο το τροφοδοτικό.
Το λαμπάκι που έχει για να δείχνει οτι συνδέθηκε καλώδιο δεν ανάβει όπως επίσης δεν δείχνει στα windows οτι είναι συνδεμένο καλώδιο πάνω.
Αρχικά τσέκαρα το mosfet που έχει πριν την έξοδο για την φόρτιση της μπαταρίας και βρήκα οτι δέχεται πολύ μεγάλη τάση στο gate με αποτέλεσμα
όπως μου είπε ένα παιδί απο το φόρουμ να μένει αποκομμένο. Κοίταξα λοιπόν τον controller που έχει για την φόρτιση το λάπτοπ. Πρόκειται για αυτό εδώ το τσιπάκι
http://www.intersil.com/data/fn/fn9258.pdf , http://www.ebay.com/itm/NEW-Intersil-ISL88731AHRZ-ISL8873-1AHRZ-ICs-/220948044602?pt=LH_DefaultDomain_0&hash=item3371879b3a
Βρήκα απο το datasheet οτι τα σημεία που με ενδιαφέρουν είναι τα ACIN, DCIN και ACOK. Λεπτομέρειες για αυτά:

DCIN
Charger Bias Supply Input. Bypass DCIN with a 0.1μF capacitor to
GND.
ACIN
AC Adapter Detection Input. Connect to a resistor divider from the
AC adapter output.
ACOK
AC Detect Output. This open drain output is high impedance
when ACIN is greater than 3.2V. The ACOK output remains low
when the ISL88731 is powered down. Connect a 10k pull-up
resistor from ACOK to VDDSMB.

Οι ενδεικτικές τάσεις που έχει για αυτά τα pin απο το datasheet είναι οι εξής:
DCIN: Min 8V, Max 26V
ACIN rising Threshold: Min 3.15V , Typ 3.2V , Max 3.25V
ACIN Threshold Hysteresis: Min 40mV , Typ 60mV, Max 90mV
ACOK at Sink Current: VACOK = 0.4V, ACIN = 1.5V
ACOK at Leakage Current: VACOK = 5.5V, ACIN = 3.7V

Οι τιμές που μετράω εγώ με κλειστό το λαπτοπ και συνδεμένο το καλώδιο είναι:
ACIN: 3.54V
DCIN: 19.48V (ακριβώς όσο του τροφοδοτικού)
ACOK: 23mV! :glare:

Από οτι καταλαβαίνω κάποιο πρόβλημα έχει η γραμμή του ACOK και δν καταλαβαίνει το λάπτοπ οτι έχω συνδεμένο καλώδιο.
Το τσιπάκι έχεi φθηνά και δεν έχω πρόβλημα να το αλλάξω αλλά υπάρχει περίπτωση να φταίει κάτι πιο πριν ή πιο μετά το τσιπάκι και να ρίχνει την τάση?
Το λαπτοπ έχει διορθωθεί απο βραχυκύκλωμα, έβαζα το τροφοδοτικό και αναβόσβηνε το λαμπάκι του, οπότε ίσως λόγω μεγάλης έντασης απο το βραχυκύκλωμα να έπαθε
κάτι αυτή η γραμμή? Σκέφτηκα επίσης να δοκιμάσω με κάποιον τρόπο να αποκόψω την έξοδο του ACOK απο το τσιπάκι και να του βάλω δικιά μου τάση σύμφωνα με το
datasheet ώστε να δω τη συμπεριφορά του. Για πείτε καμιά γνώμη.

Jimakos_Sn
21-02-12, 16:30
Λοιπόν το σκάλισα ακόμα λίγο και βρήκα και κάτι άλλο. Το σήμα απο το ACOK πάει σε ένα τρανζιστοράκι smd και απο κει στα ledάκια που δείχνουν οτι συνδέθηκε το βύσμα.

http://img17.imageshack.us/img17/4387/1001358z.jpg (http://imageshack.us/photo/my-images/17/1001358z.jpg/)


http://img818.imageshack.us/img818/8697/1001360m.jpg (http://imageshack.us/photo/my-images/818/1001360m.jpg/)

Το τρανζίστορ είναι αυτό πάνω δεξιά. Σύμφωνα με αυτό το σχεδιάγραμμα τα c b e είναι έτσι:
http://talkingelectronics.com/projects/Phone%20Ring/images/sm-resistor-1.gif
Εγώ απο τις μετρήσεις βλέπω οτι έχει το ACOK στο base και στο collector μετράω 3.27V. Στο emitter όμως που πάει στα led και λογικά
θα δίνει και το σήμα οτι μπήκε το βύσμα βλέπω 0V. Το τρανζίστορ αυτό που λέει πάνω είναι ΜΝ1 W2, δεν κατάφερα να βρω πληροφορίες.
Αν μπορεί κάποιος ας μου πει αν θα έπρεπε να διεγείρεται με τάση 23mV που έχει το ACOK ή όχι.